Activation is required each time I start Cinema 4D / I am getting a crash / Material editor previews are black!


This article applies in case of a problem such as:

  • Corona asks for activation each time Cinema 4D is restarted
  • Any rendering crashes with "fatal error" message or similar
  • All material editor previews appear black when Corona is selected as the active renderer
  • Various other issues appear - such as Corona VFB displayed incorrectly




Possible solutions


Solution A - Reset your activation files:

  1. This is the first, most important step:
    Go to C:\Users\_username_\AppData\Local\CoronaRenderer and send us the content of this folder.

  2. Go to C:\Users\_username_\AppData\Local\CoronaRenderer and make sure that none of the .txt files in there has "hidden" file attribute in its properties (Right click on a file > Properties > Attributes > Uncheck "hidden").
    Note: Make sure that you are able to see the hidden files and folders. To enable this, go to "Folder Options" in Windows settings, go to "View" tab, and make sure that "Show hidden files, folders, and drives" option is enabled.

    In case the above points did not help:

  3. Go to C:\Users\_username_\AppData\Local\CoronaRenderer and remove all files inside this folder.
    Note:
    While this is perfectly safe to do, it will require re-activation of Corona upon the next Cinema 4D launch.



Solution B - Disable the NVIDIA AI Denoiser

  1. Set Corona as your active renderer in Cinema 4D.
  2. Go to Render Settings > Corona > General settings > Denoising and set Mode to None.
  3. Go to Render Settings > Performance settings > Interactive rendering and disable the "Fast preview denoise during render" checkbox.


For macOS users:

Navigate to your ~/ Library / Application Support / Corona folder and delete its contents. 

Note: Library folders are hidden by default and if you're unfamiliar with how to "reveal" them, please see this basic guide:

https://www.macrumors.com/how-to/reveal-library-folder-in-macos/



If you are still experiencing some issues after trying the suggestions above, please contact us