How to use Distributed Rendering?


Corona Renderer for Cinema 4D uses the native Cinema 4D Team Render to handle distributed or networked rendering. It can be used in two ways, either where multiple machines contribute to rendering the same single image, or where different images are handed out to individual machines for rendering (this second option being used when rendering animations, for example, where each machine will work on a different frame).


Setting up Team Render

Setting up Team Render follows the standard processes for Cinema 4D. A summary of the steps is provided below, but full information is available from Maxon through the Cinema 4D help, and many tutorials can be found online (like one of the official Cineversity tutorials: Cinema 4D Team Render, Basic Introduction.)


1. In Cinema 4D, enable Team Render by going to Edit -> Preferences -> Renderer -> Team Render, and check "Enable Team Render"

2. For machines that will act as clients, run the Cinema 4D Client

3. Once enabled, check that the Machine List is as expected (under Render -> Team Render Machines). 


Machines can be added to this list automatically or manually (see Cinema 4D help for full details). You may need to verify the machines on the list and enter the security token for that machine (and sometimes you may need to Unverify then Verify the machine)


Note: Master and slave PC's must all be using the same version Cinema 4D, for example, R19. All instances of Corona Renderer must be the same. Mix-matching versions will result in an error. If any plugins are being used in the render, they must also be installed on all slaves. 


Setting up Team Render

Source: YouTube/Maxon


Activating Corona using the Licensing Server

Once all your machines are set up you will need to ensure that Corona has been activated on all machines that will be used for Team Render. The easiest way to do this is to use our Licensing Server. 


Activating with the Licensing Server should be a rather straight-forward process. Simply run the Licensing Server from the main PC and enter your customer zone email and password when prompted. The slaves will be automatically connected with the Licensing Server.


In the event that the above method fails, a manual approach is needed. For each client machine, you will need to create a txt file called "CoronaActivation", within this file you will need to enter your customer zone email and password in the following format: email:password (For example, johnsmith@example.com:123456)


Then save the file to the location: Library/Application Support/Corona/ for Mac and C:\Users\USERNAME\AppData\Local\CoronaRenderer for Windows, do this for all clients using Corona. Now from your main workstation (the one running the Cinema 4D interface), you can launch the licensing server. This should then hunt for the newly created txt file and activate all instances of Corona.


If you cannot find the licensing server, run the Corona installer again and choose "unpack" (for Windows) or "customize" (for Mac) then make sure the licensing server is enabled and proceed with the rest of the installation.


You can check on the client machines to see if Corona has been successfully activated. To do this, Open the Team Render Client interface on your slave machines and click on the console tab to check the status. 


Corona Renderer is successfully installed.


Using Team Render to render a single image

Once Team Render is set up as above, use the Team Render to Picture Viewer option from the Render menu. The main Cinema 4D machine plus all the machines running the Team Render Client will now work on rendering the single image. The resulting image will build up in the Picture Viewer.


You can open the Corona Post-process dialog from the Corona menu in the Picture Viewer, and use this to adjust Tone Mapping, Bloom and Glare, etc. You can also open the Corona VFB and adjust the post-processing options there. 


Using Team Render to render an animation

The same method as above can also be used for rendering animations with Team Render. Once the render has commenced, the Picture Viewer will open and a status dialog will be displayed at the bottom of the Picture Viewer and your job will be listed in the history panel. 


Note:  The rendered image will be shown once it has completed it's desired passes. It is also recommended to render out a single image to adjust any tone mapping or post-processing prior to rendering your animation. These settings can be saved via the VFB in the .conf format.



Related Article:

Corona Licensing Server